您的位置:首页 > 其它

[NWPU][2014][TRN][16]图论拓扑排序 H - 基础

2014-09-06 20:42 344 查看
H - 基础
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2367

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of
children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further,
there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it
is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0


Sample Output

2 4 5 3 1


#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;
const int MAXN = 105;
int graph[MAXN][MAXN], indegree[MAXN], ans[MAXN];
int n;

void tuopu()
{
//计算入度
for(int i = 1; i<= n; i++)
for(int j = 1; j <= n; j++)
if(graph[i][j])
indegree[j]++;
for(int i = 1; i <= n; i++)
{
int k = 1;
while(indegree[k] != 0)
k++;
ans[i] = k;
indegree[k] = -1;
for(int j = 1; j <= n; j++)
{
if(graph[k][j]) indegree[j]--;//这里写为了if(graph[i][j])终于找到错误了
//cout<< indegree[j] << endl;
}
}
}
int main()
{
//freopen("input.txt", "r", stdin);
while(cin >> n)
{
memset(graph, 0, sizeof(graph));  //忘了memset函数结果就反悔了Runtime Error(ACCESS_VIOLATION)奇葩错误
memset(indegree, 0, sizeof(indegree));
memset(ans, 0, sizeof(ans));
int a;
for(int i = 1; i <= n; i++)
{
while(cin >> a && a)
graph[i][a] = 1;
}
tuopu();
for(int i =1; i < n ; i++)
cout << ans[i] << " ";
cout << ans
<< endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: