您的位置:首页 > 其它

HDOJ 题目1439Cipher(置换群)

2014-09-06 20:32 393 查看


Cipher

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 386    Accepted Submission(s): 171


[align=left]Problem Description[/align]
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia
on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters
in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in
the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

 

[align=left]Input[/align]
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next
lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate
line the number 0. 

 

[align=left]Output[/align]
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block
there is one empty line.
 

[align=left]Sample Input[/align]

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

 

[align=left]Sample Output[/align]

BolHeol b
C RCE

 

[align=left]Source[/align]
ACM暑期集训队练习赛(5)
 

[align=left]Recommend[/align]
lcy   |   We have carefully selected several similar problems for you:  1415 1443 1427 1423 1455 
 
给一个序列a,a[ i ]表示当前在i位置,经过一次encode变到a[ i ]的位置。再给一个字符串,s0, s1, s2,...,sn-1(长度不够的用空格
补上)。s[ i ]在a[ i ]位置输出得到一个新的串,重复这个过程k次,求最后的串。

ac代码

#include<stdio.h>
#include<string.h>
int a[300],c[300];
char s[300],ans[300];
int main()
{
int n;
while(scanf("%d",&n)!=EOF,n)
{
int i,temp,k;
memset(c,0,sizeof(c));
//memset(ans,0,sizeof(ans));
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
a[i]--;
}
for(i=0;i<n;i++)//求个个点的循环节
{
if(!c[i])
{
temp=a[i];
c[i]++;
while(temp!=i)
{
c[i]++;
temp=a[temp];
}
}
}
while(scanf("%d",&k)!=EOF,k)
{
int pos,len;
getchar();
gets(s);
memset(ans,0,sizeof(ans));
len=strlen(s);
for(i=len;i<n;i++)
s[i]=' ';
s
='\0';
//k--;
for(i=0;i<n;i++)
{
temp=k%c[i];
pos=i;
while(temp--)
{
pos=a[pos];
}
ans[pos]=s[i];
}
ans
='\0';
//printf("%s\n",ans);
for(i=0;i<n;i++)
printf("%c",ans[i]);
printf("\n");
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: