您的位置:首页 > 其它

poj 2488(dfs)

2014-09-06 13:59 429 查看
题目链接:http://poj.org/problem?id=2488

A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 31012Accepted: 10613
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

思路:刚开始用广搜解题,但是后来要按字典序输出,所以改为深搜~只要注意方向数组的设置就行;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
using namespace std;

int xx[]={-1,1,-2,2,-2,2,-1,1}; //设置方向数组优化搜索
int yy[]={-2,-2,-1,-1,1,1,2,2};
bool vis[30][30];//标记状态
int n,m,flag;
int map[30][30]; //地图
int path[30][30];//存储路径

void dfs(int x,int y,int k)
{
  if(k==n*m)
  {
   for(int i=0;i<k;i++)
    printf("%c%d",64+path[i][0],path[i][1]);
   flag=1;
   return;
  }
  for(int i=0;i<8;i++)
  {
     int dx=x+xx[i];
     int dy=y+yy[i];
     if(dx>=1&&dx<=n&&dy>=1&&dy<=m&&!vis[dx][dy]&&!flag)
     {
       vis[dx][dy]=true;
       path[k][0]=dy;
       path[k][1]=dx;
       dfs(dx,dy,k+1);
       vis[dx][dy]=false;
     }
  }
}

int main()
{
        int T,test=1;
        cin>>T;
        while(T--)
        {
          scanf("%d%d",&n,&m);

          memset(vis,false,sizeof(vis));
          path[0][0]=1;
          path[0][1]=1;
          vis[1][1]=true;
          flag=0;

          printf("Scenario #%d:\n",test++);
          dfs(1,1,1);
          if(!flag)printf("impossible\n");
          else printf("\n");
          printf("\n");
        }
        return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: