您的位置:首页 > 其它

POJ3264——Balanced Lineup

2014-09-06 13:32 246 查看
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤
height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and
Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow
i

Lines N+2..N+Q+1: Two integers A and B (1 ≤
A ≤ B ≤ N), representing the range of cows from A to
B inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0

Source
USACO 2007 January Silver

可以线段树,当然我用了RMQ,明天就是网络赛了,求不爆零 ---.---

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int min_dp[50010][20];
int max_dp[50010][20];
int val[50010];
void max_rmq(int n)
{
	for(int i=1;i<=n;i++)
		max_dp[i][0]=val[i];
	for(int j=1;(1<<j)<=n;j++)
		for(int i=1;i+(1<<j)-1<=n;i++)
			max_dp[i][j]=max(max_dp[i][j-1],max_dp[i+(1<<(j-1))][j-1]);
}

void min_rmq(int n)
{
	for(int i=1;i<=n;i++)
		min_dp[i][0]=val[i];
	for(int j=1;(1<<j)<=n;j++)
		for(int i=1;i+(1<<j)-1<=n;i++)
			min_dp[i][j]=min(min_dp[i][j-1],min_dp[i+(1<<(j-1))][j-1]);
}

int st_max(int a,int b)
{
	int k=(int)(log(b-a+1.0)/log(2.0));
	return max(max_dp[a][k],max_dp[b-(1<<k)+1][k]);
}

int st_min(int a,int b)
{
	int k=(int)(log(b-a+1.0)/log(2.0));
	return min(min_dp[a][k],min_dp[b-(1<<k)+1][k]);
}

int main()
{
	int n,q;
	while(~scanf("%d%d",&n,&q))
	{
		for(int i=1;i<=n;i++)
			scanf("%d",&val[i]);
		max_rmq(n);
		min_rmq(n);
		int a,b;
		for(int i=1;i<=q;i++)
		{
			scanf("%d%d",&a,&b);
			int u=st_max(a,b);
			int v=st_min(a,b);
			printf("%d\n",u-v);
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: