您的位置:首页 > 其它

hdu 2141 Can you find it? 二分

2014-09-04 14:36 337 查看
传送门:http://acm.hdu.edu.cn/showproblem.php?pid=2141


Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 11577 Accepted Submission(s): 3031



Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.



Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth
line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.



Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".



Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10




Sample Output

Case 1:
NO
YES
NO




Author

wangye



三个数能否相加得到X; 把头两个相加,存入set. 然后X减去第三个数,一个个减过来. 然后用find在set 中二分来找,找到即是可以相加得到X;

之前全开__int64 MLE 了

开了两个set来分别存 结果TLE了

最后这样都化成int用一个set终于过了.

#include<stdio.h>
#include<set>
using namespace std;
#define ll __int64
int a[600];
int c[600];
int main()
{
	int i,l,m,r,flag,op,tem,j;
	set<int>my;
	int cas=1;
	while(scanf("%d%d%d",&l,&m,&r)!=EOF)
	{
		my.clear();
		for(i=0;i<l;i++)
		{
			scanf("%d",&a[i]);
		}
		for(i=0;i<m;i++)
		{
			scanf("%d",&tem);
			for(j=0;j<l;j++)
			{
				if((ll)tem+a[j]<=2147483647)
				my.insert(tem+a[j]);
			}
		}
		for(i=0;i<r;i++)
		{
			scanf("%d",&c[i]);
		}
		scanf("%d",&op);
		printf("Case %d:\n",cas++);
		while(op--)
		{
			scanf("%d",&tem);
			flag=0;
			for(i=0;i<r;i++)
			{
				if(my.find(tem-c[i])!=my.end())
				{
					flag=1;
					break;
				}
			}
			if(flag)
				puts("YES");
			else
				puts("NO");
		}
	}
	return 0;
}
//2147483647
/*
1 2 1
2147483647
1 0
0
3
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: