您的位置:首页 > 其它

POJ 2481 树状数组

2014-09-03 14:37 393 查看


Cows

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 12764Accepted: 4237
Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei -
Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105)
specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint
Huge input and output,scanf and printf is recommended.

题意:有一些奶牛,每个奶牛有两个整数的属性L和R,如果有另一只奶牛的Lj属性<=第i只奶牛的Li属性并且Rj >= Ri
并且Ri-Li >= Rj - Lj 就说第j只奶牛比第i只强,问对每一只奶牛,有多少奶牛比它强.

思路:暴力枚举n^2必然超时,考虑先将奶牛排序,第一关键字是L,第二关键字是R,按从小到大的顺序将奶牛插入树状数组,每次插入后查询R值>=它的所有奶牛,但要去掉L,R值都和它相等的奶牛,就能nlogn的解决了。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>

using namespace std;

# pragma comment (linker,"/STACK:16777216")

const int MAXN = 100010;
const int INF = 2100000000;

int n, maxn;
class Cow
{
public:
int pos, left, right;
};
Cow cow[MAXN*3];
int ans[MAXN];
int c[MAXN];
inline bool operator < (Cow c1, Cow c2)
{
if(c1.left != c2.left) return c1.left < c2.left;
else return c1.right > c2.right;
}
int lowbit(int x)
{
return x&(-x);
}
void update(int x)
{
while(x <= maxn)
{
c[x]++;
x += lowbit(x);
}
}
int getsum(int x)
{
int res = 0;
while(x > 0)
{
res += c[x];
x -= lowbit(x);
}
return res;
}

int main()
{
//freopen("C:/Users/zts/Desktop/in.txt", "r", stdin);
while(scanf("%d", &n) != -1 && n)
{
memset(c, 0, sizeof(c));
maxn = 0;
for(int i = 1; i <= n; i++)
{
scanf("%d%d", &cow[i].left, &cow[i].right);
cow[i].pos = i;
maxn = max(maxn, cow[i].right);
}
sort(cow+1, cow+1+n);

for(int i = 1; i <= n; i++)
{
update(cow[i].right);

ans[cow[i].pos] = i-getsum(cow[i].right-1);//R值>=Ri的奶牛个数
ans[cow[i].pos] -= 1;//减掉自身

int j = i-1;//从i-1开始往回找L值也和Li相等的减掉
while(j >= 1 && cow[i].left == cow[j].left)
{
if(cow[j].right == cow[i].right)
ans[cow[i].pos] -= 1;
j--;
}

}

for(int i = 1; i <= n; i++)
{
printf("%d ", ans[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: