您的位置:首页 > 其它

poj 1200 (hash)

2014-09-02 10:58 295 查看
Crazy Search

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 23168Accepted: 6513
Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon
will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed
16 Millions.
Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac

Sample Output
5

Hint

Huge input,scanf is recommended.
Source

Southwestern Europe 2002

题意:输入n,m,和字符窜,给你字符串出现字母的种数(m),问你长度为n的字符串有多少种?

hash,看代码吧

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
#define N 16000005

char a
;
int n,m;
int ha
;

int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%s",a);

        i=0;
        memset(ha,0,sizeof(ha));

        int len=strlen(a);

        for(j=0;j<len;j++)
        {
            if(!ha[a[j]])
            {
                ha[a[j]]=++i;
                if(i==m)
                    break;
            }
        }

        int ans=0;

        for(i=0;i+n<=len;i++)
        {
            int temp=0;
            for(j=i;j<i+n;j++)
            {
                temp=temp*m+ha[a[j]];
            }
            if(!ha[temp])
            {
                ans++;
                ha[temp]=1;
            }
        }

        printf("%d\n",ans);
        return 0;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: