您的位置:首页 > 其它

poj 1861 Network

2014-09-01 22:07 337 查看
Network

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13682 Accepted: 5311 Special Judge
Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network,
each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about
possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot
be connected to itself. There will always be at least one way to connect all hubs.
Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding
cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output
1
4
1 2
1 3
2 3
3 4


这题当时看到样例吓傻了,样例貌似是错误的,这道题目其实就是刘汝佳大白书上讲的瓶颈最小生成树,最小生成树一定是瓶颈最小生成树,而瓶颈最小生成树不一定是最小生成树。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define Maxn 15010
using namespace std;

struct line{
int u,v,w;
bool operator<(const line &a)const{
return w<a.w;
}
}edge[Maxn];
int fa[1010];
bool flag[Maxn];
void init(int n){
for(int i=1;i<=n;i++)
fa[i]=i;
}
int findset(int x){
return fa[x]==x?x:(fa[x]=findset(fa[x]));
}
void unionset(int a,int b){
fa[a]=b;
}
int kruskal(int n,int m){
int cnt=0,maxx=0;
for(int i=0;i<m;i++){
int a=findset(edge[i].u),b=findset(edge[i].v);
if(a!=b){
maxx=max(maxx,edge[i].w);
unionset(a,b);
flag[i]=true;
if(++cnt==n-1) return maxx;
}
}
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m)){
for(int i=0;i<m;i++)
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
sort(edge,edge+m);
init(n);
memset(flag,0,sizeof flag);
printf("%d\n%d\n",kruskal(n,m),n-1);
for(int i=0;i<m;i++)
if(flag[i]) printf("%d %d\n",edge[i].u,edge[i].v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: