您的位置:首页 > 其它

poj 1861 Network(最小生成树)

2014-09-01 21:11 274 查看
Network

点击打开题目链接

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 13680Accepted: 5310Special Judge
Description
Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have
access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following
M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one
way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.
Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers
of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.
Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output
1
4
1 2
1 3
2 3
3 4

Source
Northeastern Europe 2001, Northern Subregion

被坑爆了,这个样例让我纠结了好久,⊙﹏⊙b汗;

求最小生成树,并输出树的边(可以任意输出);

╮(╯▽╰)╭,样例中竟然有环,O__O"…

#include <iostream>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<queue>
#define N 1000010
using namespace std;
int visit
,parent
;
struct node
{
    int right;
    int from;
    int to;
} g
;
int map
;
void init(int n)//初始化
{
    int i;
    for(i=0; i<=n; i++)
    {
        g[i].right=0;
        g[i].from=0;
        g[i].to=0;
        parent[i]=i;
    }
}
int cmp(const void *a,const void *b)
{
    node *p1=(node *)a,*p2=(node *)b;
    return p1->right-p2->right;
}
int set_find(int x)///找父节点
{
    return parent[x]==x?x:parent[x]=set_find(parent[x]);
}
int main()
{
    int n,m,i;
    int edge,cnt;
    while(~scanf("%d%d",&n,&m))
    {
        init(n);
        memset(visit,0,sizeof(visit));
        memset(map,-1,sizeof(map));
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&g[i].from,&g[i].to,&g[i].right);
        }
        qsort(g,m,sizeof(g[0]),cmp);///按权值排序
        cnt=0;
        edge=-1;
        queue<node> q;
        for(i=0; i<m; i++)
        {
            int px=set_find(g[i].from);
            int py=set_find(g[i].to);
            if(px!=py)//合并集合
            {
                parent[px]=py;
                if(edge<g[i].right)
                    edge=g[i].right;
                cnt++;
                q.push(g[i]);
                map[px]=py;
                if(cnt==n-1)
                    break;
            }
        }
        printf("%d\n",edge);
        printf("%d\n",cnt);
        while(!q.empty())///输出边
        {
            node a=q.front();
            q.pop();
            printf("%d %d\n",a.from,a.to);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: