您的位置:首页 > 其它

HDU 4971 A simple brute force problem 最大权闭合图

2014-09-01 19:40 435 查看


A simple brute force problem.

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 375 Accepted Submission(s): 214



Problem Description

There's a company with several projects to be done. Finish a project will get you profits. However, there are some technical problems for some specific projects. To solve the problem, the manager will train his employee which may cost his budget. There may
be dependencies between technical problems, for example, A requires B means you need to solve problem B before solving problem A. If A requires B and B requires A, it means that you should solve them at the same time. You can select which problems to be solved
and how to solve them freely before finish your projects. Can you tell me the maximum profit?



Input

The first line of the input is a single integer T(<=100) which is the number of test cases.

Each test case contains a line with two integer n(<=20) and m(<=50) which is the number of project to select to complete and the number of technical problem.

Then a line with n integers. The i-th integer(<=1000) means the profit of complete the i-th project.

Then a line with m integers. The i-th integer(<=1000) means the cost of training to solve the i-th technical problem.

Then n lines. Each line contains some integers. The first integer k is the number of technical problems, followed by k integers implying the technical problems need to solve for the i-th project.

After that, there are m lines with each line contains m integers. If the i-th row of the j-th column is 1, it means that you need to solve the i-th problem before solve the j-th problem. Otherwise the i-th row of the j-th column is 0.



Output

For each test case, please output a line which is "Case #X: Y ", X means the number of the test case and Y means the the maximum profit.



Sample Input

4
2 3
10 10
6 6 6
2 0 1
2 1 2
0 1 0
1 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 1 0
1 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 1 0
0 0 0
0 0 0
2 3
10 10
8 10 6
1 0
1 2
0 0 0
1 0 0
0 0 0




Sample Output

Case #1: 2
Case #2: 4
Case #3: 4
Case #4: 6




Source

2014 Multi-University Training Contest 10



#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>

using namespace std;

const int oo=1e9+100;

const int mm=1111111;
const int mn=888;

int node,s,t,edge,max_flow;

int ver[mm],cap[mm],flow[mm],next[mm];

int head[mn],work[mn],dis[mn],q[mn];

inline void init(int _node,int _s,int _t)
{
    node=_node, s=_s, t=_t;
    for(int i=0;i<node;++i)
        head[i]=-1;
    edge=max_flow=0;
}

inline void addedge(int u,int v,int c)
{
    ver[edge]=v,cap[edge]=c,flow[edge]=0,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,cap[edge]=0,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}

bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0;i<node;++i)  dis[i]=-1;
    dis[ q[r++]=s ] = 0;
    for(l=0;l<r;l++)
    {
       for(i=head[ u=q[l] ]; ~i ;i=next[i])
        if(flow[i]<cap[i] && dis[ v=ver[i] ]<0)
        {
            dis[ q[r++]=v ]=dis[u]+1;
            if(v==t) return 1;
        }
    }
    return 0;
}

int Dinic_dfs(int u,int exp)
{
    if(u==t) return exp;
    for(int &i=work[u],v,temp; ~i ;i=next[i])
    {
        if(flow[i]<cap[i] && dis[ v=ver[i] ]==dis[u]+1 && ( temp=Dinic_dfs(v,min(exp,cap[i]-flow[i])) )>0)
        {
           flow[i]+=temp;
           flow[i^1]-=temp;
           return temp;
        }
    }
    return 0;
}

int Dinic_flow()
{
    int res,i;
    while(Dinic_bfs())
    {
        for(i=0;i<node;++i) work[i]=head[i];
        while( ( res=Dinic_dfs(s,oo) ) )  max_flow+=res;
    }
    return  max_flow;
}

int n,m,k;

int main()
{
    int T;
    int cas=1;
    cin>>T;
    while(T--)
    {
        int sum=0,x,y;
        scanf("%d%d",&n,&m);
        init(n+m+2,0,n+m+1);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            sum+=x;
            addedge(s,i,x);
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&x);
            addedge(n+i,t,x);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&k);
            for(int j=1;j<=k;j++)
            {
                scanf("%d",&y);
                addedge(i,n+y+1,oo);
            }
        }
        for(int i=n+1;i<=n+m;i++)
        {
            for(int j=n+1;j<=n+m;j++)
            {
                scanf("%d",&x);
                if(x)
                {
                    addedge(i,j,oo);
                }
            }
        }
        int ans=Dinic_flow();
        printf("Case #%d: %d\n",cas++,sum-ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: