您的位置:首页 > 其它

HDU1002 A + B Problem II

2014-09-01 00:09 357 查看
[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are
very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note
there are some spaces int the equation. Output a blank line between two test cases.
[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


大整数和

code:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1010
char a
,b
;
int num
={0};
int main()
{
int count=1,i,len,k;
int a1,b1;		//两个大数长度
int n;
scanf("%d",&n);
while(n--)
{
if(count!=1)
printf("\n");
scanf("%s%s",a,b);
a1=strlen(a);
b1=strlen(b);
k=(a1>b1)?a1:b1;
len=k;
for(k;a1>0&&b1>0;k--)
{
num[k]+=a[--a1]-'0'+b[--b1]-'0';
num[k-1]=num[k]/10;
num[k]%=10;
}
while(a1>0)
{
num[k]+=a[--a1]-'0';
num[k-1]=num[k]/10;
num[k--]%=10;
}
while(b1>0)
{
num[k]+=b[--b1]-'0';
num[k-1]=num[k]/10;
num[k--]%=10;
}
printf("Case %d:\n",count++);
printf("%s + %s = ",a,b);
for(i=0;i<len&&num[i]==0;i++);
for(;i<=len;i++)
printf("%d",num[i]);
printf("\n");
memset(num,0,sizeof(num));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: