您的位置:首页 > 其它

HDOJ 题目1211RSA(数学)

2014-08-30 01:52 351 查看


RSA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1415    Accepted Submission(s): 1017


[align=left]Problem Description[/align]
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q

> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)

> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key

> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = me mod n

When you want to decrypt data, use this method :

M = D(c) = cd mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.

 

[align=left]Input[/align]
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks. 

 

[align=left]Output[/align]
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.

 

[align=left]Sample Input[/align]

101 103 7 11
7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239

 

[align=left]Sample Output[/align]

I-LOVE-ACM.

 

[align=left]Author[/align]
JGShining(极光炫影)
 

[align=left]Source[/align]
杭电ACM省赛集训队选拔赛之热身赛
 

[align=left]Recommend[/align]
Eddy   |   We have carefully selected several similar problems for you:  1299 1214 1222 1695 1210 
 
ac代码

#include<stdio.h>
__int64 n;//注意n要为64位
__int64 pow(int a,int b)
{
int i;
__int64 s=1;
for(i=0;i<b;i++)
s=(s*a)%n;
return s;
}
int main()
{
int p,q,e,l,a;
while(scanf("%d%d%d%d",&p,&q,&e,&l)!=EOF)
{
int i=1,d;
n=(p-1)*(q-1);
while(1)
{
if((e*i)%n==1)
break;
i++;
}
d=i;
n=p*q;
for(i=0;i<l;i++)
{
scanf("%d",&a);
printf("%c",pow(a,d));
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: