您的位置:首页 > 其它

Bomb - HDU 3555 数位dp

2014-08-29 16:52 369 查看


Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 7741 Accepted Submission(s): 2712



Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would
add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?



Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.



Output

For each test case, output an integer indicating the final points of the power.



Sample Input

3
1
50
500




Sample Output

0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.




思路:和上一篇 不要62 是一样的,就不多说了。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll dp[21][3];
int num[30];
ll solve(ll n)
{ ll ans=0,ret=n;
  int i,j,k,len=0;
  bool flag=false;
  while(ret)
  { num[++len]=ret%10;
    ret/=10;
  }
  num[len+1]=0;
  for(i=len;i>0;i--)
  { ans+=dp[i-1][2]*num[i];
    if(flag)
     ans+=dp[i-1][0]*num[i];
    if(!flag && num[i]>4)
     ans+=dp[i-1][1];
    if(num[i+1]==4 && num[i]==9)
     flag=true;
  }
  return ans;
}
int main()
{ int t,i,j,k;
  ll n;
  dp[0][0]=1;
  for(i=1;i<=20;i++)
  { dp[i][0]=dp[i-1][0]*10-dp[i-1][1];
    dp[i][1]=dp[i-1][0];
    dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
  }
  scanf("%d",&t);
  while(t--)
  { scanf("%I64d",&n);
    printf("%I64d\n",solve(n+1));
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: