您的位置:首页 > 其它

NYOJ 5 Binary String Matching

2014-08-27 08:30 281 查看


Binary String Matching

时间限制:3000 ms | 内存限制:65535 KB
难度:3

描述Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is
‘11’, you should output 3, because the pattern A appeared at the posit

输入The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And
it is guaranteed that B is always longer than A.
输出For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3

/*题解:

由于数据很小,可以按最基础的思想将字符串s1与字符串s2的0下标开始,一个字符一个字符的匹配

完全匹配sum++,然后从s2的下个字符开始,继续匹配进行上述操作,一直到s2所有字符匹配完毕。

*/

#include<cstdio>
#include<cstring>
int main()
{
	int i,j,n,len1,len2,t,sum,now;
	char s1[12],s2[1010];
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s %s",s1,s2);
		len1=strlen(s1);
		len2=strlen(s2);
		for(i=0,sum=0; i<len2; i++)
		{
			now = i;
			for(j=0,t=0; j<len1; j++)
			{
				if(s1[j]==s2[now])
				{
					t++;
					now++;
				}
			}
			if(t==len1)
				sum++;
		}
		printf("%d\n",sum);
	}
}

最优代码:



/*代码解析

m = s2.find(s1,0);从下标0开始查找字符串,返回s1与s2开始匹配的下标。

string :: npos是一个常数,用来表示不存在的位置。

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: