您的位置:首页 > 其它

POJ2533(最长上升子序列)

2014-08-26 10:32 204 查看
经典dp:设置数组dp[i]为如果取第i个数最长的个数,dp[0]为1,dp[i] 为max(dp[j])(0<=j<i 且a[i]>a[j]),然后最后的答案为max(dp[i])(0<=i<n)

题目描述:

Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 33577 Accepted: 14694

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered
subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7

1 7 3 5 9 4 8

Sample Output

4

ac代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
#define N 1005
using namespace std;

int a
, dp
;
int main()
{
int n;
while(~scanf("%d", &n)){
for(int i=0; i<n; i++)
scanf("%d", &a[i]);

memset(dp, 0, sizeof dp);
dp[0] = 1;
for(int i=0; i<n; i++){
int tmax = 0;
for(int j=0; j<i; j++){
if(a[j] < a[i]){
if(dp[j] > tmax)
tmax = dp[j];
}
}
dp[i] = tmax+1;
}

int ans = 0;
for(int i = 0; i<n; i++){
if(ans < dp[i])
ans = dp[i];
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: