您的位置:首页 > 其它

[POJ 3264]Balanced Lineup(ST算法求RMQ)

2014-08-25 21:09 405 查看
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤
height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and
Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow
i

Lines N+2..N+Q+1: Two integers A and B (1 ≤
A ≤ B ≤ N), representing the range of cows from A to
B inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output
6
3
0

Source
USACO 2007 January Silver
题目很水,裸的RMQ自然不必多说,对于每次询问输出区间最大值与最小值绝对值之差,不过要注意输入输出用cin cout会超时,只能用scanf printf,最终速度为1719ms

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

#define MAXN 50100

using namespace std;

int max(int a,int b)
{
if(a>b) return a;
return b;
}

int min(int a,int b)
{
if(a<b) return a;
return b;
}

int minRMQ[MAXN][18],maxRMQ[MAXN][18];

int getMinRMQ(int l,int r)
{
int pos=(int)(log((r-l+1)*1.0)/log(2.0));
return min(minRMQ[l][pos],minRMQ[r-(1<<pos)+1][pos]);
}

int getMaxRMQ(int l,int r)
{
int pos=(int)(log((r-l+1)*1.0)/log(2.0));
return max(maxRMQ[l][pos],maxRMQ[r-(1<<pos)+1][pos]);
}

int main()
{
int n,m,q;
scanf("%d%d",&n,&q);
for(int i=1;i<=n;i++)
{
scanf("%d",&minRMQ[i][0]);
maxRMQ[i][0]=minRMQ[i][0];
}
m=(int)(log(n*1.0)/log(2.0));
for(int i=1;i<20;i++)
for(int j=1;j<=n;j++)
{
if(j+(1<<i)-1<=n)
{
maxRMQ[j][i]=max(maxRMQ[j][i-1],maxRMQ[j+(1<<(i-1))][i-1]);
minRMQ[j][i]=min(minRMQ[j][i-1],minRMQ[j+(1<<(i-1))][i-1]);
}
}
for(int i=1;i<=q;i++)
{
int a,b;
scanf("%d%d",&a,&b);
printf("%d\n",getMaxRMQ(a,b)-getMinRMQ(a,b));
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: