您的位置:首页 > 其它

hdu3743——Frosh Week

2014-08-25 20:29 232 查看
Problem Description
During Frosh Week, students play various fun games to get to know each other and compete against other teams. In one such game, all the frosh on a team stand in a line, and are then asked to arrange themselves according to some criterion,
such as their height, their birth date, or their student number. This rearrangement of the line must be accomplished only by successively swapping pairs of consecutive students. The team that finishes fastest wins. Thus, in order to win, you would like to
minimize the number of swaps required.


Input
The first line of input contains one positive integer n, the number of students on the team, which will be no more than one million. The following n lines each contain one integer, the student number of each student on the team. No
student number will appear more than once.



Output
Output a line containing the minimum number of swaps required to arrange the students in increasing order by student number.



Sample Input
3
3
1
2




Sample Output
2




Source
University of Waterloo Local Contest 2010.10.02



Recommend

一开始没离散化,错了2次

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int tree[1000010];
int arr[1000010];
struct node
{
	int Id;
	__int64 v;
}val[1000010];

int n;

int cmp(node a,node b)
{
	return a.v<b.v;
}

inline int lowbit(int x)
{
	return x&(-x);
}

void add(int x,int val)
{
	for(int i=x;i<=1000010;i+=lowbit(i))
		tree[i]+=val;
}

__int64 sum(int x)
{
	__int64  ans=0;
	for(int i=x;i;i-=lowbit(i))
		ans+=tree[i];
	return ans;
}

int main()
{
	while(~scanf("%d",&n))
	{
		__int64 ans=0;
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++)
		{
			scanf("%I64d",&val[i].v);
			val[i].Id=i;
		}
		sort(val+1,val+n+1,cmp);
		for(int i=1;i<=n;i++)
			arr[val[i].Id]=i;	
		for(int i=1;i<=n;i++)
		{
			add(arr[i],1);
			ans+=i-sum(arr[i]);
		}
		printf("%I64d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: