您的位置:首页 > 其它

poj 1328 Radar Installation (贪心)

2014-08-25 20:06 453 查看
Radar Installation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 52823Accepted: 11883
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1


思路 :在X轴上肯定有个区域,雷达在这个区域内可以把某个小岛覆盖住;然后把这些区域按左区间排序,然后贪心的求解就行了。
这些仔细考率都能过的,因为一个变量搞成int型竟然错了好久!

#include"stdio.h"
#include"string.h"
#include"math.h"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 1005
struct node
{
double l,r;
}p
;
double x
,y
;
bool cmp(node a,node b)
{
return a.l<b.l;
}
int main()
{
int i,n,d,cnt=1,flag;
while(scanf("%d%d",&n,&d),n||d)
{
flag=0;
for(i=0;i<n;i++)
{
scanf("%lf%lf",&x[i],&y[i]);
if(flag)
continue;
if(d<y[i])
flag=1;
double t=sqrt(d*d-y[i]*y[i]);
p[i].l=x[i]-t;
p[i].r=x[i]+t;
}
printf("Case %d: ",cnt++);
if(flag)
{
printf("-1\n");
continue;
}
sort(p,p+n,cmp);
int t=1;
double rr;
rr=p[0].r;
for(i=1;i<n;i++)
{
if(p[i].l>rr)   //该区间不能被雷达覆盖住
{
rr=p[i].r;
t++;
}
if(p[i].r<rr)  //可以被当前雷达作用,
{
rr=p[i].r;
}
}
printf("%d\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: