您的位置:首页 > 其它

hdu 1087 Super Jumping! Jumping! Jumping!(DP 两个for循环,比较最靠近小于它的的子列最大值)

2014-08-25 13:41 441 查看

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22479 Accepted Submission(s): 9890

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.



Input
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.



Output
For each case, print the maximum according to rules, and one line one case.



Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0




Sample Output
4
10
3




Author
lcy
题意分析:
给出一系列数据,第一个是总棋子数,之后的是每个棋子的数值,规则,后者必须要比前面走的棋子的数值大,求解的是经过的棋子的总和。
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10010],sum[10010];//sum用来存储棋子总和,a[i]是用来存储每次存储的棋子的数值
int main()
{
	int n,i;
	while(~scanf("%d",&n),n)
	{
		memset(a,0,sizeof(a));
		memset(sum,0,sizeof(sum));
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		int temp,maxn=-1,j;//temp用来表示每次的前者的最大值。
		for(i=0;i<n;i++)
		{
			temp=0;
			for(j=i-1;j>=0;j--)
			{
				if(a[j]<a[i]&&temp<sum[j])
				temp=sum[j];//temp是用来表示其那面的i-1 个值中的最大值。
			}
				sum[i]+=temp+a[i];//第i个数值 与前面的所有数据的数据和
				maxn=max(maxn,sum[i]);//比较其余前面的i-1个数的最大值。
			
		}
		printf("%d\n",maxn);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐