您的位置:首页 > 编程语言 > C语言/C++

hdoj 1003 Max Sum

2014-08-25 11:51 281 查看

                                    Max Sum

                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

                                               Total Submission(s): 145802    Accepted Submission(s): 34043


[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

 

AC CODE:

#include<algorithm>
using namespace std;
int main()
{
int i,j,T,temp,start,end;
scanf("%d",&T);
for(i=1;i<=T;i++)
{
if(i!=1)
printf("\n");
int n,sum=0,c,max=-99999999;
temp=0;start=0;end=0;
scanf("%d",&n);
for(j=0;j<n;j++)
{
scanf("%d",&c);
sum+=c;
if(sum>max)
{
start=temp;
end=j;
max=sum;
}
if(sum<0)         //sum<0,意味着前面不可能再有相加比max大的情况了,sum值已为负,再与后面的数相加会”拖累 ”后面的数,所以应清零sum重新进行相加检索
{
sum=0;
temp=j+1;
}
}
printf("Case %d:\n",i);                                     //cout<<"Case "<<j<<":"<<endl;
printf("%d %d %d\n",max,start+1,end+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c语言 杭电