您的位置:首页 > 其它

2417_Lowest Bit

2014-08-25 11:45 274 查看
Lowest Bit

Time Limit: 2 Seconds
Memory Limit: 65536 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26

88

0



Sample Output


2

8

Author: SHI, Xiaohan

Source: Zhejiang University Local Contest 2005

给一个10进制数, 求它二进制后, 从最低位1开始构成的数。88的二进制为1011000,1000 结果是 8 26 的二进制为 11010 10 结果是 2 循环取余,找到第一个 1 为止

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int num;
int a;
int count;
while(cin>>num&&num)
{
count=0;
while(num!=0)//二进制依次从低位到高位求
{
a=num%2;
if(a==0)
count++;
else//遇到第一个1即停止
break;
num=num/2;

//cout<<a<<endl;
}
cout<<pow(2,count)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: