您的位置:首页 > 其它

POJ 2255 Tree Recovery(二叉树重建)

2014-08-23 22:33 489 查看
Tree Recovery

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11443 Accepted: 7182
Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations: 
D

/ \

/   \

B     E

/ \     \

/   \     \

A     C     G

/

/

F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 

Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB

Source

Ulm Local 1997

题意:输入一棵二叉树的先序遍历和中序遍历序列,输出它的后续遍历序列。

分析:先序遍历的第一个字符就是根,因此只需在中序遍历中找到它,就可以知道左右子树的先序遍历和后序遍历了。

#include <stdio.h>
#include <string.h>

char s[30],s1[30],s2[30];

void build(int n, char s1[],char s2[],char s[]){
if(n<=0)
return;
int p=strchr(s2,s1[0])-s2;
build(p,s1+1,s2,s);
build(n-p-1,s1+p+1,s2+p+1,s+p);
s[n-1]=s1[0];
}
int main(){
while(scanf("%s%s",s1,s2)==2){
int n=strlen(s1);
build(n,s1,s2,s);
s
='\0';
printf("%s\n",s);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: