您的位置:首页 > 其它

[2602]Bone Collector (HDU)

2014-08-23 20:03 204 查看
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1


Sample Output

14


01背包

#include <string.h>

#include <stdio.h>

#include <stdlib.h>

int w[1100],v[1100],bg[1100];

int main()

{

int z,n,m,i,j;

scanf("%d",&z);

while(z--)

{

memset(bg,0,sizeof(bg));

scanf("%d %d",&n,&m);

getchar();

for(i=0;i<n;i++)

scanf("%d",&w[i]);

for(i=0;i<n;i++)

scanf("%d",&v[i]);

for(i=0;i<n;i++)

{

for(j=m;j>=v[i];j--)//从后向前

{

if(bg[j]<bg[j-v[i]]+w[i])

bg[j]=bg[j-v[i]]+w[i];

}

}

printf("%d\n",bg[m]);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: