您的位置:首页 > 其它

HDOJ 题目2717 Catch That Cow(BFS)

2014-08-23 14:56 232 查看


Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7202    Accepted Submission(s): 2274


Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of
transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input

Line 1: Two space-separated integers: N and K

 

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

 

Sample Input

5 17

 

Sample Output

4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

Source

USACO 2007 Open Silver

 

Recommend

teddy   |   We have carefully selected several similar problems for you:  2102 1372 1240 1180 1253 

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int n,k;
int v[100010],d[100010];

void bfs()
{
queue<int>q;
q.push(n);
while(!q.empty())
{
int u=q.front();
if(u==k)return;
q.pop();
int next=u-1;
if(next>=0&&next<1000001&&!d[next])
{
q.push(next);
d[next]=d[u]+1;
v[next]=1;
}
next=u+1;
if(next>=0&&next<100001&&!d[next])
{
q.push(next);
d[next]=d[u]+1;
v[next]=1;
}
next=u*2;
if(next>=0&&next<100001&&!d[next])
{
q.push(next);
d[next]=d[u]+1;
v[next]=1;
}
}
}
int main()
{
while(scanf("%d%d",&n,&k)!=EOF)
{
//queue<int>q;
memset(v,0,sizeof(v));
memset(d,0,sizeof(d));
v
=1;
//q.push(n);
bfs();
printf("%d\n",d[k]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: