您的位置:首页 > 其它

题目1002:Grading

2014-08-23 14:01 337 查看
题目描述:
Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other,
a judge is invited to make the final decision. Now you are asked to write a program to help this process.

For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:

• A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.

• If the difference exceeds T, the 3rd expert will give G3.

• If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.

• If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.

• If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:
Each input file may contain more than one test case.

Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:
For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18


样例输出:
14.0


#include<stdio.h>

#include<math.h>

int max(int a,int b)

{

if(a>b)

return a;

else

return b;

}

int main()

{

int P,T,G1,G2,G3,GJ;

while(scanf("%d %d %d %d %d %d",&P,&T,&G1,&G2,&G3,&GJ)!=EOF)

{

if(abs(G1-G2)<=T)

printf("%0.1lf\n",(G1+G2)/2.0);

else if((abs(G1-G3)<=T||abs(G2-G3)<=T)&&(abs(G1-G3)>T||abs(G2-G3)>T))

{

int tmp1=abs(G1-G3);

int tmp2=abs(G2-G3);

if(tmp1>tmp2)

printf("%0.1lf\n",(G2+G3)/2.0);

else

printf("%0.1lf\n",(G1+G3)/2.0);

}

else if(abs(G1-G3)<=T&&abs(G2-G3)<=T)

printf("%0.1lf\n",(double)max(max(G1,G2),G3));

else if(abs(G1-G3)>T&&abs(G2-G3)>T)

printf("%0.1lf\n",(double)GJ);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: