您的位置:首页 > 其它

Remember the Word - UVaLive 3942 Trie树+dp

2014-08-21 21:49 295 查看
Neal is very curious about combinatorial problems, and now here comes a problem about words. Knowing that Ray has a photographic memory and this may not trouble him, Neal gives it to Jiejie.
Since Jiejie can't remember numbers clearly, he just uses sticks to help himself. Allowing for Jiejie's only 20071027 sticks, he can only record the remainders of the numbers divided by total amount of sticks.
The problem is as follows: a word needs to be divided into small pieces in such a way that each piece is from some given set of words. Given a word and the set of words, Jiejie should calculate the number of ways
the given word can be divided, using the words in the set.

Input

The input file contains multiple test cases. For each test case: the first line contains the given word whose length is no more than 300 000.
The second line contains an integer S , 1

S

4000 .
Each of the following S lines contains one word from the set. Each word will be at most 100 characters long. There will be no two identical words and all letters in the words will
be lowercase.
There is a blank line between consecutive test cases.
You should proceed to the end of file.

Output

For each test case, output the number, as described above, from the task description modulo 20071027.

Sample Input

abcd 
4 
a 
b 
cd 
ab


Sample Output

Case 1: 2


题意:问你原串由下面的子串拼接而成的方式有多少种。

思路:之前做过一道差不多的,UVaLive2426/article/1969281.html。那道用的是KMP+dp。但是正确的做法是Trie树,这道用KMP会T。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int dp[301010],MOD=20071027,n,m;
char s[301010],s2[1100];
struct Trie
{ int index;
  Trie *next[26];
  Trie()
  { index=-1;
    memset(next,0,sizeof(next));
  }
};
Trie *root=new Trie;
void Trie_Insert(Trie *tr,char *s)
{ if(*s!='\0')
  { if(tr->next[*s-'a']==0)
     tr->next[*s-'a']=new Trie;
    Trie_Insert(tr->next[*s-'a'],s+1);
  }
  else
   tr->index=1;
}
void Trie_Search(Trie *tr,int start,int len)
{ if(tr->index!=-1)
  { dp[start+len]+=dp[start];
    dp[start+len]%=MOD;
  }
  if(start+len>=n)
   return;
  if(tr->next[s[start+len]-'a']!=0)
   Trie_Search(tr->next[s[start+len]-'a'],start,len+1);

}
int main()
{ int t=0,i,j,k;
  while(~scanf("%s",s))
  { Trie *root=new Trie;
    n=strlen(s);
    scanf("%d",&m);
    for(i=1;i<=m;i++)
    { scanf("%s",s2);
      Trie_Insert(root,s2);
    }
    memset(dp,0,sizeof(dp));
    dp[0]=1;
    for(i=1;i<=n;i++)
     Trie_Search(root,i-1,0);
    printf("Case %d: %d\n",++t,dp
);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: