您的位置:首页 > 其它

hdoj.1390 Binary Numbers 20140821

2014-08-21 21:07 183 查看

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2779 Accepted Submission(s): 1717

[align=left]Problem Description[/align]
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

[align=left]Input[/align]
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

[align=left]Output[/align]
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

[align=left]Sample Input[/align]

1
13


[align=left]Sample Output[/align]

0 2 3
#include<stdio.h>
#include<string.h>
int main()
{
int t,n,i,j,s[50];
scanf("%d",&t);
while(t--){
scanf("%d",&n);
int x=2;
memset(s,0,sizeof(s));
for(i=1;;i++){
if(x*2>n) break;
x*=2;
}
j=i;
while(n>=0){
if(n-x>=0){
s[j]=1;
n-=x;
}
//else x/=2;
if(j==0) break;
x/=2;
j--;
}
x=0;
for(j=0;j<=i;j++){
if(s[j]){
if(x==0){
printf("%d",j);x++;
}
else printf(" %d",j);
}
}
printf("\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: