您的位置:首页 > 产品设计 > UI/UE

hdoj 1047 Integer Inquiry

2014-08-21 19:11 218 查看

http://acm.hdu.edu.cn/showproblem.php?pid=1047

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12628    Accepted Submission(s): 3198


[align=left]Problem Description[/align]
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

 

[align=left]Input[/align]
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

 

[align=left]Output[/align]
Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

[align=left]Sample Input[/align]

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

 

[align=left]Sample Output[/align]

370370367037037036703703703670
#include<stdio.h>
#include<string.h>
#define MAX 10000
int main()
{
int N,i,j,k,n,a[MAX],b[MAX];
char s[MAX];
scanf("%d",&N);
while(N--)
{
memset(a,0,sizeof(a));
while(scanf("%s",s)&&s[0]!='0')
{
memset(b,0,sizeof(b));
n=strlen(s);
for(j=0,i=n-1;i>=0;i--,j++)
b[j]=s[i]-'0';
for(i=0;i<MAX;i++)
{
a[i]+=b[i];
if(a[i]>=10)
{
a[i]-=10;
a[i+1]+=1;
}
}
}
for(i=MAX-1;i>0;i--)
if(a[i]!=0) break;
for(;i>=0;i--)
printf("%d",a[i]);
printf("\n");
if(N!=0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: