您的位置:首页 > 大数据 > 人工智能

UVA - 10494 If We Were a Child Again

2014-08-21 09:44 525 查看
Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

 

 


The Problem

 

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

 

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent
enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

 

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily
long. The second number n will be in the range (0 < n < 231).

 

[b]  [/b]
[b]Output[/b]
A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

 

[b]  [/b]
[b]  [/b]
[b]Sample Input[/b]
110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

 

 

 

 

 
 
[b]Sample Output[/b]
1

9

1

2147483646

#include<stdio.h>
#include<string.h>
char m[2000000];
int n[2000000];
int main()
{
char a;
long long y,sum;
int i,j,x;
while(scanf("%s",m)!=EOF){
while((a=getchar())&&a==' ')
;
scanf("%lld",&y); //第二个数不需要变成字符串
x=strlen(m);
if(a=='/'){
sum=0;
for(i=0;i<x;i++){
sum=sum*10+m[i]-'0';
n[i]=sum/y;
sum=sum-n[i]*y;
}
i=0;
while(n[i]==0&&i<x-1)
i++;
for(;i<x;i++)
printf("%d",n[i]);
printf("\n");
}
else {
sum=0;
for(i=0;i<x;i++){
sum=sum*10+m[i]-'0';
sum=sum-sum/y*y;
}
printf("%lld\n",sum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息