您的位置:首页 > 其它

Crazy Search+POJ+字符串哈希

2014-08-21 08:32 357 查看
Crazy Search

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 23006Accepted: 6460
Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon
will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed
16 Millions.
Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac

Sample Output
5

解决方案:寻找连续子串长度为3的不同子串的长度,首先不同字符的个数为NC,所以先对这些不同字符编码,然后把子串转成一个NC进制的数字,基本实现0冲突,所以可以开一个16milions的数组来标记出现过的子串。这是一种字符串哈希。

code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX 17000000
using namespace std;
int NC,N;
char text[MMAX];
bool vis[MMAX];
int num[200];
int main()
{
while(~scanf("%d %d\n%s",&N,&NC,text))
{
int len=strlen(text);
// cout<<text<<endl;
int seed=0;
memset(num,-1,sizeof(num));
memset(vis,false,sizeof(vis));
for(int i=0; i<len; i++)
{
if(num[text[i]]==-1)
{
num[text[i]]=seed++;
// if(seed==NC) break;
}
}
// cout<<seed<<endl;
int cnt=0;
for(int i=0; i<=len-N; i++)
{
int res=0;
for(int j=i; j<i+N; j++)
{
res=res*NC+num[text[j]];
}
if(!vis[res])
{
vis[res]=true;
cnt++;
}

}
printf("%d\n",cnt);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: