您的位置:首页 > 产品设计 > UI/UE

Crixalis's Equipment

2014-08-20 21:45 344 查看
Problem Description


Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground
and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis
has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely
Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.


Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs
of integers: Ai and Bi.

0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.


Output

For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

Sample Input

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11



Sample Output

Yes
No




此题意为将设备搬进体积为V的空间,没件设备有存储空间和运输空间,a,b两个量,必须这两个量同时满足才可以。对于两件设备a1,b1和a2,b2,运输的先后顺序起很大作用,要想使结果最优,必须先将体积大的运送进去,但不只是仅仅靠a,b排序就能解决。先1后2,则运输过程中需要的最大空间为a1+b2,而

#include<iostream>//差值排序

#include<map>

//#include<set>

#include<algorithm>

#define maxn 2000

using namespace std;

struct node{

int a,b;

friend bool operator <(node x,node y){

if(y.a+x.b>=x.a+y.b) return true;

else return false;

}

}nd[maxn];

int main(){

int num,b,a,n,m;

while(cin>>num){

while(num-->0){

cin>>n>>m;

bool flag=true;

// mp.clear();

for(int i=0;i<m;i++){

cin>>nd[i].a>>nd[i].b;

}

sort(nd,nd+m);

/* for(int i=0;i<m;i++){

cout<<nd[i].a<<nd[i].b<<endl;

}*/

for(int i=0;i<m;i++){

if(n>=nd[i].b){

n-=nd[i].a;

}

else{

flag=false;

break;

}

}

if(n<0) flag=false;

if(flag) cout<<"Yes"<<endl;

else cout<<"No"<<endl;

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: