您的位置:首页 > 其它

FatMouse's Speed(HDU 1160)—— DP记录路径

2014-08-19 22:38 309 查看

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9284 Accepted Submission(s): 4125

Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing,
but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],...,
m
then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m
]

and

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900


Sample Output
4
4
5
9
7


Source
Zhejiang University Training Contest 2001

题意:给你许多组数据,没组两个数,一个代表老鼠的重量,一个代表老鼠的速度,为了证明老鼠越重速度越慢,让你取出几组数据证明,问最多能取出几组。体重要严格递增,速度严格递减。

这题是最长上升子序列问题,只是还需要输出其路线。我学会了DP记录路径^_^
#include<cstdio>
#include<algorithm>
using namespace std;
struct Node
{
    int W, S, num; //记录体重、速度、序号
}p[1010];
bool cmp(Node c, Node d) {return c.W < d.W;}

int main()
{
    int n = 1, i, j, dp[1010], pre[1010], ans[1010];

    while(~scanf("%d%d", &p
.W,&p
.S))
        p
.num = n++;
    sort(p+1, p+n+1, cmp); //对体重由小到大排序
    int len = 0, final; 
    for(i=1; i<=n; i++)
    {
        dp[i] = 1; //dp指最小长度
        for(j=1; j<i; j++)
        {
            if(p[j].S > p[i].S && p[j].W < p[i].W)
            if(dp[j]+1 > dp[i]) //转移方程
            {
                dp[i] = dp[j]+1;
                pre[i] = j; //pre数组记录前驱序号结点
            }
        }
        if(dp[i] > len)
        {
            len = dp[i];
            final = i; //final指dp更新的最后一个序号结点
        }
    }
    printf("%d\n", len);
    for(i=1; i<=len; i++)
    {
        ans[i] = final; //ans数组记录从最后序号的结点到第一个序号的结点,方便逆序输出
        final = pre[final]; 
    }
    for(i=len; i>=1; i--) //p[].num才是真正的序号
        printf("%d\n", p[ans[i]].num);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: