您的位置:首页 > 其它

POJ 3187 Backward Digit Sums(dfs)

2014-08-19 21:08 337 查看
Backward Digit Sums

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4281Accepted: 2470
Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example,
one instance of the game (when N=4) might go like this:

3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities.

Write a program to help FJ play the game and keep up with the cows.
Input

Line 1: Two space-separated integers: N and the final sum.
Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16

Sample Output
3 1 2 4

Hint

Explanation of the sample:

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.
Source

USACO 2006 February Gold & Silver
这个题意就是给你一个n和m,然后n个数排列后像上面的那样计算出一个数,如果和m想同就ok,输出最小的序列

思路:

直接dfs枚举每个序列,如果有满足结束,不过我代码中有个传地址的地方让我bug了几分钟,细节在代码中

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 20

int a
,ans
;
int vis
;
int n,m;
int yes;

int fdd(int a[],int n)
{
    if(n==1)  return a[0];

    int i;
    for(i=0;i<n-1;i++)
        a[i]=a[i]+a[i+1];

    return fdd(a,n-1);
}

void dfs(int pos)
{
    int i;
    if(yes)  return ;

    if(pos==n)
    {
        for(i=0;i<n;i++) //这里必须把ans转移到a数组中,
                         //因为下面是地址传递会改变数组的值
            a[i]=ans[i];

            if(fdd(a,n)==m)
            {
              for(i=0;i<n;i++)
                if(i==0)
                  printf("%d",ans[i]);
                 else
                  printf(" %d",ans[i]);

                yes=1;
            }
        return ;
    }

    for(i=1;i<=n;i++)
        if(!vis[i])
    {
        vis[i]=1;
        ans[pos]=i;
        dfs(pos+1);
        vis[i]=0;
    }

}

int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
         yes=0;
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            vis[i]=1;
            ans[0]=i;
            dfs(1);
            vis[i]=0;
        }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: