您的位置:首页 > 其它

pojn 1861 Network(Kruskal)

2014-08-19 14:28 375 查看
题目链接:http://poj.org/problem?id=1861

Description
Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have
access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following
M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one
way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers
of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output
1
4
1 2
1 3
2 3
3 4

Source
Northeastern Europe 2001, Northern Subregion

题意是求最小生成树中的最大边长,并输出生成树的边。Sample有问题。。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1005;
const int inf=1<<31-1;
struct node
{
int u,v;
int cost;
}E[maxn*maxn];
int f[maxn];
int cnt;
int ret[maxn];
int cmp(node a,node b)
{
return a.cost<b.cost;
}
int find(int x)
{
if(f[x]!=x)
f[x]=find(f[x]);
return f[x];
}
int kruskal(int ne)
{
int maxcost=0;
cnt=0;
for(int i=0;i<ne;i++)
{
int f1=find(E[i].u);
int f2=find(E[i].v);
if(f1!=f2)
{
ret[cnt++]=i;
f[f1]=f2;
maxcost=max(maxcost,E[i].cost);
}
}
return maxcost;
}
int n,m;
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d %d",&n,&m)==2)
{
memset(ret,0,sizeof(ret));
for(int i=0;i<=n;i++)
f[i]=i;
for(int i=0;i<m;i++)
scanf("%d %d %d",&E[i].u,&E[i].v,&E[i].cost);
sort(E,E+m,cmp);
int ans=kruskal(m);
printf("%d\n",ans);
printf("%d\n",cnt);
for(int i=0;i<cnt;i++)
printf("%d %d\n",E[ret[i]].u,E[ret[i]].v);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: