您的位置:首页 > 其它

HDU 3625 Examining the Rooms(斯特林数)

2014-08-19 11:06 459 查看

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1052 Accepted Submission(s): 634


[align=left]Problem Description[/align]
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap!
You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and
the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.

To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch
the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force,
then repeat the procedure above, until all the rooms are examined.

Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You
want to know what is the possibility of that you can examine all the rooms finally.

[align=left]Input[/align]
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)

[align=left]Output[/align]
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.

[align=left]Sample Input[/align]

3
3 1
3 2
4 2

[align=left]Sample Output[/align]

0.3333
0.6667
0.6250
Hint
Sample Explanation

When N = 3, there are 6 possible distributions of keys:

Room 1 Room 2 Room 3 Destroy Times
#1 Key 1 Key 2 Key 3 Impossible
#2 Key 1 Key 3 Key 2 Impossible
#3 Key 2 Key 1 Key 3 Two
#4 Key 3 Key 2 Key 1 Two
#5 Key 2 Key 3 Key 1 One
#6 Key 3 Key 1 Key 2 One

In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1.
In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room

[align=left]Source[/align]
2010 Asia Regional Tianjin Site —— Online Contest

[align=left]Recommend[/align]
lcy

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <sstream>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <ctime>
using namespace std;
typedef long long LL;

LL s[100][100];

int main(){

int t = 0;
for(int i = 0;i<=30;i++){
s[i][0] = 0;
}
s[1][1] = 1;
for(int i = 1;i<30;i++){
for(int k = 1;k<30;k++){
s[i+1][k] = s[i][k-1]+i*s[i][k];
}
}
//	for(int i = 1;i<30;i++){
//		for(int k = 1;k<30;k++){
//			cout<<s[i][k]<<" ";
//		}
//		cout<<endl;
//	}
//	while(scanf("%d",&t)!=EOF){
scanf("%d",&t);
while(t--){
int a,b;
scanf("%d%d",&a,&b);
double sum = 1;
double sum2 = 0;

for(int i = 1;i<=a;i++){
sum = sum * i;
}
for(int i = 1;i<=b;i++){
sum2 += s[a][i] - s[a-1][i-1];
}
//	cout<<sum<<" "<<sum2<<endl;
printf("%.4lf\n",(double)sum2/sum);
}
//	}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息