您的位置:首页 > 其它

poj 3164 Command Network(最小树形图朱刘算法)

2014-08-19 10:17 531 查看
题目链接:http://poj.org/problem?id=3164

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must
be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The
nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all
pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integerN (N ≤ 100), the number of nodes in the destroyed network, and
M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The nextN lines each contain an ordered pair
xi and yi, giving the Cartesian coordinates of the nodes. Then followM lines each containing two integers
i and j between 1 andN (inclusive) meaning a wire can be built between node
i and nodej for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘
poor snoopy
’.

Sample Input
4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output
31.19
poor snoopy

Source
POJ Monthly--2006.12.31, galaxy

题意,是给定你n个点的坐标,然后是m个这些点的关系,用点的距离作为花费,建图,然后直接求最小树形图,经典的朱刘算法求解。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
const int maxn=1100;
const int inf=1<<31-1;
struct  point
{
int x,y;
}P[maxn*maxn];
struct node
{
int u,v;
double cost;
}E[maxn*maxn];
int pre[maxn],vis[maxn],ID[maxn];
double In[maxn];
int n,m;
double get_dis(int s,int t)
{
int x1=P[s].x;
int y1=P[s].y;
int x2=P[t].x;
int y2=P[t].y;
return sqrt((x1-x2)*(x1-x2)*1.0+(y1-y2)*(y1-y2)*1.0);
}
double zhuliu(int root,int nv,int ne)
{
double ret=0;
while(true)
{
for(int i=0;i<nv;i++)
In[i]=inf;
for(int i=0;i<ne;i++)
{
int u=E[i].u;
int v=E[i].v;
if(E[i].cost<In[v]&&u!=v)
{
pre[v]=u;
In[v]=E[i].cost;
}
}
for(int i=0;i<nv;i++)
{
if(i==root) continue;
if(In[i]==inf) return -1;
}
int cnt=0;
memset(ID,-1,sizeof(ID));
memset(vis,-1,sizeof(vis));
In[root]=0;
for(int i=0;i<nv;i++)
{
ret+=In[i];
int v=i;
while(vis[v]!=i&&ID[v]==-1&&v!=root)
{
vis[v]=i;
v=pre[v];
}
if(v!=root&&ID[v]==-1)
{
for(int u=pre[v];u!=v;u=pre[u])
ID[u]=cnt;
ID[v]=cnt++;
}
}
if(cnt==0) break;
for(int i=0;i<nv;i++)
{
if(ID[i]==-1)
ID[i]=cnt++;
}
for(int i=0;i<ne;i++)
{
int v=E[i].v;
E[i].u=ID[E[i].u];
E[i].v=ID[E[i].v];
if(E[i].u!=E[i].v)
E[i].cost-=In[v];
}
nv=cnt;
root=ID[root];
}
return ret;
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d %d",&n,&m)==2)
{
for(int i=0;i<n;i++)
scanf("%d %d",&P[i].x,&P[i].y);
for(int i=0;i<m;i++)
{
int s,t;
scanf("%d %d",&s,&t);
E[i].u=s-1;
E[i].v=t-1;
E[i].cost=get_dis(s-1,t-1);
//printf("cost=%lf ",E[i].cost);
}
//        for(int i=0;i<m;i++)
//            printf("%d %d %lf\n",E[i].u,E[i].v,E[i].cost);
double ans=zhuliu(0,n,m);
if(ans==-1)
printf("poor snoopy\n");
else
printf("%.2lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: