您的位置:首页 > 其它

hdu 1102 Constructing Roads(最小生成树 Prim)

2014-08-19 09:04 423 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.



Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.



Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.



Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2




Sample Output

179


代码如下:

#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
#define MAXN 517
//创建m二维数组储存图表,low数组记录每2个点间最小权值,visited数组标记某点是否已访问
int m[MAXN][MAXN], low[MAXN], visited[MAXN];
int n;
int prim( )
{
    int i, j;
    int pos, minn, result=0;
    // memset(visited,0,sizeof(visited));
    for(i = 1; i <= n; i++)
        visited[i] = 0;
    visited[1] = 1;
    pos = 1;          //从某点开始,分别标记和记录该点
    for(i = 1; i <= n; i++)     //第一次给low数组赋值
    {
        if(i != pos)
            low[i] = m[pos][i];
        else
            low[i] = 0;
    }
    for(i = 1; i <= n; i++) //再运行n-1次
    {
        minn = INF;   //找出最小权值并记录位置
        pos = -1;
        for(j = 1; j <= n; j++)
        {
            if(visited[j]==0 && minn>low[j])
            {
                minn = low[j];
                pos = j;
            }
        }
        if(pos == -1)
            continue;
        result += minn;   //最小权值累加
        visited[pos] = 1;   //标记该点
        for(j = 1; j <= n; j++)   //更新权值
            if(!visited[j] && low[j]>m[pos][j])
                low[j] = m[pos][j];
    }
    return result;
}
int main()
{
    int tt;
    while(~scanf("%d",&n))
    {
        memset(m,INF,sizeof(m));   //所有权值初始化为最大
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                scanf("%d",&tt);
                if(tt < m[j][i])
                    m[i][j] = m[j][i] = tt;
            }
        }
        int Q, a, b;
        scanf("%d",&Q);
        for(int i = 0; i < Q; i++)
        {
            scanf("%d%d",&a,&b);
            m[a][b] = m[b][a] = 0;
        }
        int ans = prim( );
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: