您的位置:首页 > 其它

HDU 1541 Stars (树状数组)

2014-08-18 22:59 543 查看
[align=left]Problem Description[/align]
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

[align=left]Input[/align]
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one
point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

[align=left]Output[/align]
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

[align=left]Sample Input[/align]

5
1 1
5 1
7 1
3 3
5 5


[align=left]Sample Output[/align]

1
2
1
1
0


直接统计不大于当前数的个数,然后hash记录。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <set>
#include <stack>
#include <cctype>
#include <algorithm>
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
using namespace std;
typedef long long LL;
const int mod = 99999997;
const int MAX = 0x3f3f3f3f;
const int maxn = 15050;
const int N = 32005;
int n, a, b;
int c
, ans[maxn];
int main()
{
while(~scanf("%d", &n)) {
memset(c, 0, sizeof(c));
memset(ans, 0, sizeof(ans));
int k = 0;
for(int i = 1; i <= n; i++) {
scanf("%d%d", &a, &b); a++;
int sum = 0;
for(int j = a; j > 0; j -= j&(-j)) sum += c[j];
for(int j = a; j <= N; j += j&(-j)) c[j]++;
ans[sum]++;
}
for(int i = 0; i < n; i++) printf("%d\n", ans[i]);
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: