您的位置:首页 > 其它

HDU 1069 Monkey and Banana ( 动态规划 )

2014-08-18 20:43 471 查看


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7572 Accepted Submission(s): 3902

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


分析: 因为每块砖最多有3个不同的底面和高度,因此先把每块砖看成三种不同的砖,每种砖只有一个底面和一个
高度。n种类型的砖转化为3*n个不同的砖的叠加,对这3 * n个砖的边长从大到小排序(按边排序);接下来的问题就是找到一个递减的子序列,使得子序列的高度和最大即可。[ 最大递减子序列和(动态规划)]
数组dp: dp[i]表示是以第i块积木为顶的塔的最大高度
因此可得状态转移方程: dp[i] = max(dp[i],dp[j] + r[i].z) (满足砖 j 的底面长和宽都大于砖 i 的长和宽)


代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 105
struct brick
{
int x,y,z;
} r[MAXN];
int dp[MAXN];
bool cmp(const brick aa,const brick bb)
{
if(aa.x==bb.x) return aa.y>bb.y;
return aa.x>bb.x;
}
int main()
{
int n,i,j,maxn;
int a,b,c,ans=1;
while(scanf("%d",&n)!=EOF)
{
if(n==0) break;
for(i=0; i<3*n; i++)
{
scanf("%d%d%d",&a,&b,&c);
r[i].x=max(a,b);
r[i].y=min(a,b);
r[i].z=c;
i++;
r[i].x=max(b,c);
r[i].y=min(b,c);
r[i].z=a;
i++;
r[i].x=max(a,c);
r[i].y=min(a,c);
r[i].z=b;
}
maxn=0;
sort(r,r+3*n,cmp);
memset(dp,0,sizeof(dp));
for(i=0; i<3*n; i++)
{
dp[i]=r[i].z;
for(j=i-1; j>=0; j--)
if(r[j].x>r[i].x&&r[j].y>r[i].y)
if(dp[j]+r[i].z>dp[i])
dp[i]=dp[j]+r[i].z;
if(dp[i]>maxn)
maxn=dp[i];
}
printf("Case %d: maximum height = %d\n",ans++,maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: