您的位置:首页 > 其它

nyoj-148-fibonacci数列(二)

2014-08-18 20:10 337 查看


fibonacci数列(二)

时间限制:1000 ms  |  内存限制:65535 KB
难度:3

描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the
Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is


.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

输入The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1


样例输出
0
34
6875

矩阵的快速幂

#include<stdio.h>
#include<string.h>
int main()
{
int n,i,j,k;
while(scanf("%d",&n)&&n!=-1)
{
int a[2][2]={1,0,1,0};
int b[2][2]={1,1,1,0};
int c[2][2];
while(n)
{
if(n&1)
{
memset(c,0,sizeof(c));
for(i=0;i<2;i++)
for(j=0;j<2;j++)
for(k=0;k<2;k++)
c[i][k]+=(a[i][j]*b[j][k])%10000;
for(i=0;i<2;i++)
for(j=0;j<2;j++)
a[i][j]=c[i][j];
}
memset(c,0,sizeof(c));
for(i=0;i<2;i++)
for(j=0;j<2;j++)
for(k=0;k<2;k++)
c[i][k]+=(b[i][j]*b[j][k])%10000;
for(i=0;i<2;i++)
for(j=0;j<2;j++)
b[i][j]=c[i][j];
n>>=1;
}
printf("%d\n",a[1][1]%10000);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: