您的位置:首页 > 其它

uva 11584 字符串 dp

2014-08-18 10:17 316 查看
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2631

Problem H: Partitioning by Palindromes



We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.
A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition
of 'racecar' into two groups.
Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number
of groups needed for a given string such that every group is a palindrome?
For example:
'racecar' is already a palindrome, therefore it can be partitioned into one group.
'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

题目大意:
                 找出回文子串的最少数量

解题思路:

                状态转移方程:dp[i]=min(dp[j]+1,dp[i]),(j+1,i)是一个回文串

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int n;
char a[1004];
int dp[1111];
bool judge(int x,int y)
{
/*for(int i=x;i<=y;i++)
printf("%c",a[i]);
printf("\n");*/
for(int i=x;i<=(x+y)/2;i++)
{
//printf("(%c %c)\n",a[x],a[y-(i-x)]);
if(a[i]!=a[y-(i-x)])
return false;
}
return true;
}

int main()
{
while(~scanf("%d%*c",&n))
{
for(int k=0;k<n;k++)
{
scanf("%s",a+1);
int m=strlen(a+1);
memset(dp,0x3f3f3f,sizeof(dp));
dp[0]=0;
dp[1]=1;
for(int i=1;i<=m;i++)
for(int j=0;j<i;j++)
if(judge(j+1,i))
dp[i]=min(dp[j]+1,dp[i]);
printf("%d\n",dp[m]);
}
}
return 0;
}
/**
int main()
{
int n,m;
scanf("%s",a+1);
while(scanf("%d%d",&n,&m))
{
printf("%d\n",judge(n,m));
}
return 0;
}
**/

         
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: