您的位置:首页 > 其它

hdu 1071 The area

2014-08-17 21:07 281 查看


The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7608 Accepted Submission(s): 5330



Problem Description

Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the
area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222


Sample Output

33.33
40.69

Hint
For float may be not accurate enough, please use double instead of float.


一道高数题 就是求出曲线和直线的方程在积分就好了!(曲线的方程可用顶点式 y = a(x-h)^2+l, (h,L) 为顶点坐标)

#include <iostream>
#include <stdio.h>
using namespace std;
double h,L,a,b,k;
double f(double x)
{
return  a*(x-h)*(x-h)*(x-h)/3+L*x-k*x*x/2-b*x;
}
int main()
{
int t;
double x1,y1,x2,y2,x3,y3;
cin>>t;
while (t--)
{
cin>>x1>>y1>>x2>>y2>>x3>>y3;
h=x1;
L=y1;
a=(y2-y1)/((x2-x1)*(x2-x1));
k=(y3-y2)/(x3-x2);
b=y2-k*x2;
printf("%.2lf\n",f(x3)-f(x2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: