您的位置:首页 > 其它

UVA - 1482 Playing With Stones

2014-08-17 11:31 465 查看
Description



You and your friend are playing a game in which you and your friend take turns removing stones from piles. Initially there areN piles with
a1,a2, a3,...,
aN number of stones. On each turn, a player must remove at least one stone from one pile but no more than half of the number of stones in that pile. The player who cannot make any moves is considered lost. For example, if there are
three piles with 5, 1 and 2 stones, then the player can take 1 or 2 stones from first pile, no stone from second pile, and only 1 stone from third pile. Note that the player cannot take any stones from the second pile as 1 is more than half of 1 (the size
of that pile). Assume that you and your friend play optimally and you play first, determine whether you have a winning move. You are said to have a winning move if after making that move, you can eventually win no matter what your friend does.

Input

The first line of input contains an integer T(T

100) denoting
the number of testcases. Each testcase begins with an integerN
(1

N

100)
the number of piles. The next line contains N integersa1,
a2, a3,...,aN
(1

ai

2*
1018) the number of stones in each pile.

Output

For each testcase, print ``YES" (without quote) if you have a winning move, or ``NO" (without quote) if you don‟t have a winning move.

Sample Input

4 
2 
4 4 
3 
1 2 3
3 
2 4 6
3 
1 2 1


Sample Output

NO 
YES 
NO 
YES

题意:有n堆石头,分别有a1,a2...an个。两个游戏者轮流操作,每次可以选一堆,拿走至少一个石子,但不能拿走超过一半的石子
思路:组合游戏和的问题,SG函数的应用,由于ai的范围太大,我们尝试先写递推程序,找规律,打出表后,发现当n为偶数的时候,SG(n)=n/2,n为奇数的时候,SG(n)=SG(n/2)
打表程序:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100;

int SG[maxn], vis[maxn];

int main() {
	SG[1] = 0;
	for (int i = 2; i <= 30; i++) {
		memset(vis, 0, sizeof(vis));
		for (int j = 1; j*2 <= i; j++)
			vis[SG[i-j]] = 1;
		for (int j = 0; ; j++) 
			if (!vis[j]) {
				SG[i] = j;
				break;
			}
		printf("%d ", SG[i]);
	}
	printf("\n");
	return 0;
}
正解:
[code]#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;

ll SG(ll x) {
return x&1?SG(x/2):x/2;
}

int main() {
int t;
scanf("%d", &t);
while (t--) {
int n;
ll a, v = 0;
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%lld", &a);
v ^= SG(a);
}
if (v)
printf("YES\n");
else printf("NO\n");
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: