您的位置:首页 > 其它

UVA - 122 Trees on the level

2014-08-17 09:22 513 查看

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental
to many algorithms in computer graphics.
This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have
have fewer than 256 nodes.
In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.
For example, a level order traversal of the tree



is: 5, 4, 8, 11, 13, 4, 7, 2, 1.
In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given
be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR).
The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each
tree is (). No whitespace appears between left and right parentheses.
All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value
or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()


Sample Output

5 4 8 11 13 4 7 2 1
not complete


#include<cstdio>
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;

const int maxn = 1000;
char s[maxn];
bool failed;
vector<int > ans;
struct node
{
bool have_value;
int v;
node *left,*right;
node():have_value(false),left(NULL),right(NULL) {}
};
node* root;
node* newnode()
{
return new node();
}

void addnode(int v,char *s)
{
int n=strlen(s);
node* u=root; //从根结点开始开始往下走
for(int i=0; i<n; i++)
{
if(s[i]=='L')
{
if(u->left==NULL) u->left=newnode(); //节点不存在,建立新节点
u=u->left; //往左走
}
else if(s[i]=='R')
{
if(u->right==NULL) u->right=newnode();
u=u->right;
}
}
if(u->have_value)
{
failed = true; //已经赋值过,说明输入有错误
}
u->v=v;
u->have_value=true;//重新的标记
}

bool read_input()
{
failed = false;
root = newnode();
for(;;)
{
if(scanf("%s",s)!=1) return false;//输入结束
if(!strcmp(s,"()")) break;//读到结束标识符,退出循环
int v;
sscanf(&s[1],"%d",&v);//读入节点值
addnode(v,strchr(s,',')+1);//查找逗号,然后插入节点
}
return true;
}

bool bfs(vector<int>& ans)
{
queue<node*> q;
ans.clear();
q.push(root);
while(!q.empty())
{
node* u=q.front();
q.pop();
if(!u->have_value) return false; //节点没有赋值过,说明输入错误
ans.push_back(u->v); //增加到尾部
if(u->left!=NULL) q.push(u->left); //放入队列
if(u->right!=NULL) q.push(u->right);//放入队列
}
return true; //输入正确
}

void pri_out()
{
int t=0;
for(int i=0; i<ans.size(); i++)
{
if(i) printf(" ");
printf("%d",ans[i]);
}
printf("\n");
ans.clear();
}

int main()
{
while(read_input())
{
bfs(ans);
if(failed||!bfs(ans)) printf("not complete\n");
else pri_out();
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息