您的位置:首页 > 其它

HDU 1074 Doing Homework(状压DP)

2014-08-17 09:10 393 查看
Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.



Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.



Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3




Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.




Author

Ignatius.L


第一道状态压缩DP.状压DP思想就是利用二进制(好多都用)的 01表示某种状态,在本题中就是某门课程做没做。
在递推关系的时候对于DP[i]看它是否包含某种作业,即能否通过做某种作业来达到dp[i].感谢:点击打开链接
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
const int maxn=1<<15;
char s[20][110];
int dp[maxn],t[maxn],pre[maxn];//dp[i]储存做作业的各种状态,t[i]表示经过的时间,pre[i]表示某种状态的的前驱
int dead[20],fin[20];
void print(int x)
{
   if(!x)
      return ;
   print(x-(1<<pre[x]));
   printf("%s\n",s[pre[x]]);
}
int main()
{
    int tt,n;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d",&n);
        memset(t,0,sizeof(t));
        memset(pre,0,sizeof(pre));
        for(int i=0;i<n;i++)
            scanf("%s%d%d",&s[i],&dead[i],&fin[i]);
        int end=1<<n;
        for(int i=1;i<end;i++)
        {
            dp[i]=INT_MAX;
            for(int j=n-1;j>=0;j--)//从后往前枚举
            {
                int temp=1<<j;
                if(!(i&temp))
                    continue;
                int cost=t[i-temp]+fin[j]-dead[j];//时间消耗
                if(cost<0)
                    cost=0;
                if(dp[i]>dp[i-temp]+cost)
                {
                    dp[i]=dp[i-temp]+cost;
                    t[i]=t[i-temp]+fin[j];
                    pre[i]=j;
//                    cout<<i<<" "<<j<<endl;
                }
            }
        }
        printf("%d\n",dp[end-1]);//end-1是每种作业都完成的状态
        print(end-1);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: