您的位置:首页 > 其它

POJ—1852—Ants—【入门题】【想法题】

2014-08-16 23:44 295 查看
Ants

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 9698Accepted: 4285
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time.

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207

Source

Waterloo local 2004.09.19
《挑战程序设计竞赛》【巫泽俊,庄俊元,李津羽】P19
看似很麻烦的一道题,其实只要想一下两只蚂蚁相遇时的情况,虽然是各自返回,

但是因为速度是一样的,所以可以看做是交错而过。。。【这就是关键!】

所以

最少时间,就是蚂蚁离最近一端的距离的最大值。

最多时间,就是蚂蚁离最远一端的距离的最大值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
#define LL __int64

int main()
{
int cases,len,n,maxn,minn,temp;
scanf("%d",&cases);
while(cases--)
{
scanf("%d%d",&len,&n);
maxn=minn=0;
for(int i=0;i<n;i++)
{
scanf("%d",&temp);
temp=temp>len-temp?len-temp:temp;   //先求出该蚂蚁离最近的一端的距离
if(temp>minn)   //更新minn,最近距离的最大值,就是最少时间
minn=temp;
temp=len-temp;  //因为temp是该只蚂蚁离最近的一端的距离,所以用杆子的长度减一下,就是离最远的一端的距离
if(temp>maxn)   //更新maxn,最远距离的最大值,就是最多时间
maxn=temp;
}
printf("%d %d\n",minn,maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: