您的位置:首页 > 其它

TOJ 1923. Tanning Salon

2014-08-16 21:57 330 查看
头大的一题,不知道是哪里错了,也不知道应该怎么理解,网上的代码在这组数据的结果不一样

2 ABCDBACD

不知道如果一个顾客来了发现满了就算他离开时有空位还算离开还是不算

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write
a program that tells the company how many customers left without tanning.

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed
by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair.
Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input
2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output
All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.

#include<iostream>
using namespace std;
const int MAX = 60;

int main(){
int n, i, id, ans;
char str[MAX];
bool vis[MAX], tan[MAX];
while(cin >> n && n){
memset(vis, 0, sizeof(vis));
memset(tan, 0, sizeof(tan));
cin >> str;
ans = 0;
for(i = 0; i < strlen(str); i ++){
id = str[i] - 'A';
if(!vis[id]){
vis[id] = true;
if(n > 0){
n --;
tan[id] = true;
}else ans ++;
}else{
if(tan[id]) n ++;
}
}
if(ans == 0)printf("All customers tanned successfully.\n");
else printf("%d customer(s) walked away.\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: