您的位置:首页 > 其它

Big Event in HDU+完全背包问题

2014-08-16 10:36 218 查看


Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23526 Accepted Submission(s): 8297



Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the
facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1


Sample Output

20 10
40 40解决方案:典型的完全背包问题,可用分解法,分解成1,2,..,..,n[i]-2^k;个物品,进行01背包求解。code:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
int v,n;
} bag[55];
int n;
int dp[5000005];
int main()
{
while(~scanf("%d",&n)&&n>=0)
{
// if(n==-1) break;
int sum=0;
for(int i=0; i<n; i++)
{
scanf("%d%d",&bag[i].v,&bag[i].n);
sum+=bag[i].v*bag[i].n;
}
for(int i=0; i<=sum; i++) dp[i]=0;
for(int i=0; i<n; i++)
{
int k=1;
int cnt=bag[i].n;
while(1)
{
cnt-=k;
if(cnt<0)
{
cnt+=k;
break;
}
for(int j=sum; j>=bag[i].v*k; j--)
{
dp[j]=max(dp[j],dp[j-bag[i].v*k]+bag[i].v*k);
}
// cout<<k<<endl;
k=k*2;
}
//cout<<cnt<<endl;
for(int j=sum; j>=bag[i].v*cnt; j--)
{
dp[j]=max(dp[j],dp[j-bag[i].v*cnt]+bag[i].v*cnt);
}
///分解后的01背包
}
int x=dp[sum/2];
int y=sum-x;
if(x<y)
{
int temp=x;
x=y;
y=temp;
}
printf("%d %d\n",x,y);
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: