您的位置:首页 > 其它

poj 1733 Parity game 并查集 离散化

2014-08-15 14:03 519 查看
点击打开链接题目链接

Parity game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6249Accepted: 2413
Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether
this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have
received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.
Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The
number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence)
and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).
Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying
all the given conditions, then number X should be the number of all the questions asked.
Sample Input
10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output
3


给出a-b范围内有偶数或者奇数个1

找出最先错误的那句话

离散可以取余10000然后如果有相同的余数 建立邻接表

代码:

#include<cstdio>
#include<cstring>
int father[10010];
struct Node
{
    int name;
    int next;
}node[10010];
int head[10010];
int res[10010];
int t;
int find(int x)
{
    if(x==father[x])
        return x;
    int t=father[x];
    father[x]=find(father[x]);
    res[x]=(res[x]+res[t])%2;
    return father[x];
}
int addname(int x)
{
    int xx=x%10010;
    for(int e=head[xx];e!=-1;e=node[e].next)
    {
        if(node[e].name==x)
        {
            return e;
        }
    }
    node[t].next=head[xx];
    head[xx]=t;
    node[t].name=x;
    return t++;
}
int main()
{
    int len,n;
    int flag,ans;
    int i;
    int a,b;
    char str[10];
    int x,y;
    int fx,fy;
    int w;
    while(scanf("%d %d",&len,&n)!=EOF)
    {
        flag=0;
        t=1;
        for(i=1;i<=2*n;i++)
        {
            father[i]=i;
            res[i]=0;
        }
        ans=0;
        memset(head,-1,sizeof(head));
        for(i=1;i<=n;i++)
        {
            scanf("%d %d %s",&a,&b,str);
            if(flag)
                continue;
            if(str[0]=='e')
            {
                w=0;
            }
            else
                w=1;
            x=addname(a-1);
            y=addname(b);
         //   printf("x = %d y = %d\n",x,y);
            fx=find(x);
            fy=find(y);
           // printf("fx = %d fy = %d\n",fx,fy);
            if(fx!=fy)
            {
                if((res[x]==res[y])==w)
                    res[fx]=1;
                else res[fx]=0;
                father[fx]=fy;
            }
            else
            {
                if((res[x]!=res[y]&&w==0)||(res[x]==res[y]&&w==1))
                {
                    ans=i-1;
                    flag=1;
                }
            }
        //    printf("res[x] = %d res[y] = %d w = %d \n",res[x],res[y],w);
        }
        if(ans==0)
        {
            printf("%d\n",n);
        }
        else
        {
            printf("%d\n",ans);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: