您的位置:首页 > 其它

POJ 1753 Flip Game (DFS)

2014-08-15 10:12 447 查看
Flip Game
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30686Accepted: 13350
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's
black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's
impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4

Source
Northeastern Europe 2000

题目链接 :http://poj.org/problem?id=1753

题目大意 :4*4的格子里有白色和黑色的圆,每次从中选一个翻,没翻一次其上下左右的都会跟着翻,问至少翻多少次能全部变成黑的或者全部变成白的

题目分析 :用dfs搜索求解,详细见代码,本题也可以将点值转化成二进制用bfs做

#include <cstdio>
int map[5][5], step,flag;

void change(int i, int j) 
{ 
    map[i][j] = !map[i][j];  //当前和四周的全翻
    if(i > 1)
        map[i-1][j] = !map[i-1][j];
    if(i < 4)
        map[i+1][j] = !map[i+1][j];
    if(j > 1)
        map[i][j-1] = !map[i][j-1];
    if(j < 4)
        map[i][j+1] = !map[i][j+1];
}

int judge()  //判断是否全为黑或者白
{
    for(int i = 1; i <= 4; i++)
        for(int j = 1; j <= 4; j++)
            if(map[i][j] != map[1][1])
                return 0;
    return 1;
}

void dfs(int i, int j, int s)
{
    if(s == step)          //当s等于当前翻的次数时,判断是否可能
    {
        flag = judge();
        return;
    }
    if(flag || i == 5)     //当flag为真或者走完所有步时return
        return;
    change(i,j);           //改变(i,j)点的值
    if(j < 4)              //从左往右从上往下走
        dfs(i, j+1, s+1);       
    else
        dfs(i+1, 1, s+1);
    change(i,j);            //再次改变该点值相当于没变
    if(j < 4)               //直接搜索后面的
        dfs(i, j+1, s);
    else
        dfs(i+1, 1, s);
    return;
}

int main()
{
    char str[5];
    for(int i = 1; i <= 4; i++)
    {
        scanf("%s", str + 1);
        for(int j = 1; j <= 4; j++)
        {
            if(str[j] == 'w')
                map[i][j] = 1;      //白色值设为1
            else
                map[i][j] = 0;      //黑色值设为0
        }
    }
    //每个格子变化1次,若一个格子变化两次则是多余的,因为相当于没变
    for(step = 0; step <= 16; step++)
    {   
        flag = 0;
        dfs(1,1,0);
        if(flag)
            break;
    }
    if(flag)
        printf("%d\n",step);
    else
        printf("Impossible\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: